Konia z obstalunkiem

No więc co ja tak dokładnie dziś robiłem, echh, no więc.

Zmieniałem moją aplikację shadenfreude żeby była oparta o framework seam w wersji 2.2.X, zamiast na wersji 2.0.X.

Zaczęło się od tego że wynajolem sobie serwer (a w zasadzie vps), no i postawiłem na nim JBossa 5.1.0.GA i postanowiłem na owym JBossie postawić również shadenfreunde. Okazało się jednak że z dziwnych przyczyn1 seam 2.0 i jboss 5.0 nie działają razem. Oczywiście nigdzie to nie jest napisane, po prostu podczas deploymentu (wrzucania na serwer) seam rzygał potężnym wyjątkiem z którego nic nie dało się wywnioskować.

OK. Zmienić biblioteki łatwo. Ściągnąłem sobie odpowiednią wersję seama, zmieniłem biblioteki i … program się nie kompiluje. Otóż między wersjami seama 2.0 a 2.1 nastąpiły drobne zmiany, które nie dotyczą większości aplikacji (ale dotyczyły mojej).

W tym momencie zacząłem się zastanawiać czy:

  • Nie użyć u mnie jednak Jbossa 4.2 — ale nie bo ja musze mieć najnowsze zabawki
  • Czy nie postawić obu obok siebie — ale nie, bo JBoss jest ramożerny i nie chce mi się konfigurować ich żeby się nie gryzły (to nie takie trudne ale trzeba ileśtam portów poprzestawiać).

No więc dziś walczyłem z czymś czego nie ma w migration guide :(. Jak ktoś chce zrozumieć z czym to proszę tu.

No więc konia z obstalunkiem dam za przyjaciela który zrozumie moje rozterki problemy i flustracje.

Wszystkie prawa zastrzeżone. Chcesz wykorzystać te materiały? Daj mi znać (mail, komentarz na forum, prywatna wiadomość) -- na pewno się zgodzę.